package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\s*\/p\s*>\s*<\s*p\s*>`)
var str = `< p >lorem ipsum etc< /p > < p >lorem ipsum...< /p >`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}