const regex = /<\s*\/p\s*>\s*<\s*p\s*>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\s*\\\/p\\s*>\\s*<\\s*p\\s*>', '')
const str = `< p >lorem ipsum etc< /p > < p >lorem ipsum...< /p >`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}