using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+(?:,\d+)*(?:\R\d+(?:,\d+)*)+$";
string input = @"ABC
1,234,543
DFGHH
1234
HRHYTTJ
JTJYMYUY
1,456
23,567
23,567
hhtyjtyj
43,679
1969Q3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}