use strict;
my $str = 'ABC
1,234,543
DFGHH
1234
HRHYTTJ
JTJYMYUY
1,456
23,567
23,567
hhtyjtyj
43,679
1969Q3';
my $regex = qr/^\d+(?:,\d+)*(?:\R\d+(?:,\d+)*)+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}