re = /^\d+(?:,\d+)*(?:\R\d+(?:,\d+)*)+$/m
str = 'ABC
1,234,543
DFGHH
1234
HRHYTTJ
JTJYMYUY
1,456
23,567
23,567
hhtyjtyj
43,679
1969Q3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end