import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(?:,\\d+)*(?:\\R\\d+(?:,\\d+)*)+$";
final String string = "ABC\n"
+ "1,234,543\n"
+ "DFGHH\n"
+ "1234\n"
+ "HRHYTTJ\n"
+ "JTJYMYUY\n"
+ "1,456\n"
+ "23,567\n"
+ "23,567\n"
+ "hhtyjtyj\n"
+ "43,679\n"
+ "1969Q3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}