$re = '/^\d+(?:,\d+)*(?:\R\d+(?:,\d+)*)+$/m';
$str = 'ABC
1,234,543
DFGHH
1234
HRHYTTJ
JTJYMYUY
1,456
23,567
23,567
hhtyjtyj
43,679
1969Q3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);