# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/DATA.*SCIENTIST|SCIENTIST.*DATA//gm;t' <<< "DATA ANALYTIC SCIENTIST
BEST DATA SCIENTIST
DATA SCIENTIST
DATA SCIENTIST
SCIENTIST DATA
"