// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)DATA.*SCIENTIST|SCIENTIST.*DATA").unwrap();
let string = "DATA ANALYTIC SCIENTIST
BEST DATA SCIENTIST
DATA SCIENTIST
DATA SCIENTIST
SCIENTIST DATA
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}