import re
regex = re.compile(r"DATA.*SCIENTIST|SCIENTIST.*DATA", flags=re.MULTILINE)
test_str = ("DATA ANALYTIC SCIENTIST\n"
"BEST DATA SCIENTIST\n"
"DATA SCIENTIST\n"
"DATA SCIENTIST\n"
"SCIENTIST DATA\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)