#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)DATA.*SCIENTIST|SCIENTIST.*DATA"
Local $sString = "DATA ANALYTIC SCIENTIST" & @CRLF & _
"BEST DATA SCIENTIST" & @CRLF & _
"DATA SCIENTIST" & @CRLF & _
"DATA SCIENTIST" & @CRLF & _
"SCIENTIST DATA" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)