using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z]{1,2}\d{1,2}[A-Z]? \d{1}[ABDEFGHJLMNPQRSTUWXYZ]{2})";
string input = @"EC1A 1BB";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}