import Foundation
let pattern = #"([A-Z]{1,2}\d{1,2}[A-Z]? \d{1}[ABDEFGHJLMNPQRSTUWXYZ]{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"EC1A 1BB"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}