re = /([A-Z]{1,2}\d{1,2}[A-Z]? \d{1}[ABDEFGHJLMNPQRSTUWXYZ]{2})/
str = 'EC1A 1BB'
# Print the match result
str.match(re) do |match|
puts match.to_s
end