const regex = new RegExp('([A-Z]{1,2}\\d{1,2}[A-Z]? \\d{1}[ABDEFGHJLMNPQRSTUWXYZ]{2})', '')
const str = `EC1A 1BB`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}