package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Z]{1,2}\d{1,2}[A-Z]? \d{1}[ABDEFGHJLMNPQRSTUWXYZ]{2})`)
var str = `EC1A 1BB`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}