const regex = /^(?:\+?(?:(?:\d){1,3}[ .-]?))?\(?(?:\d{3})\)?[ .-]?\d{3}[ .-]?\d{4}$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\+?(?:(?:\\d){1,3}[ .-]?))?\\(?(?:\\d{3})\\)?[ .-]?\\d{3}[ .-]?\\d{4}$', 'gmi')
const str = `+1 951-543.1630
9515431630
951.543.1630
951-543-1630
(951)-543-1630
951 543 1630
4000220220448316
300 951 543 1630
12 852 456 1562
1562215622`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}