re = /^(?:\+?(?:(?:\d){1,3}[ .-]?))?\(?(?:\d{3})\)?[ .-]?\d{3}[ .-]?\d{4}$/mi
str = '+1 951-543.1630
9515431630
951.543.1630
951-543-1630
(951)-543-1630
951 543 1630
4000220220448316
300 951 543 1630
12 852 456 1562
1562215622'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end