use strict;
my $str = '1&1&1{1:1}';
my $regex = qr/1&1&1{1:1}/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";