# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\$.*?ccc\\1234\\.*?;)//gm;t' <<< "$(SolDir)..\..\ABC\ccc\1234\ccc_am_system;$(SolDir)..\..\ABC\ccc\1234\ccc_am_system\host;$(SolDir)..\..\ABC\ccc\1234\components\fds\ab_cdef_1.0\host; $(SolDir)..\..\ABC\ccc\1234\somethingelse;"