$re = '/(\$.*?ccc\\\\1234\\\\.*?;)/m';
$str = '$(SolDir)..\\..\\ABC\\ccc\\1234\\ccc_am_system;$(SolDir)..\\..\\ABC\\ccc\\1234\\ccc_am_system\\host;$(SolDir)..\\..\\ABC\\ccc\\1234\\components\\fds\\ab_cdef_1.0\\host; $(SolDir)..\\..\\ABC\\ccc\\1234\\somethingelse;';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;