use strict;
my $str = '$(SolDir)..\\..\\ABC\\ccc\\1234\\ccc_am_system;$(SolDir)..\\..\\ABC\\ccc\\1234\\ccc_am_system\\host;$(SolDir)..\\..\\ABC\\ccc\\1234\\components\\fds\\ab_cdef_1.0\\host; $(SolDir)..\\..\\ABC\\ccc\\1234\\somethingelse;';
my $regex = qr/(\$.*?ccc\\1234\\.*?;)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";