# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\$.*?ccc\\1234\\.*?;)"
test_str = "$(SolDir)..\\..\\ABC\\ccc\\1234\\ccc_am_system;$(SolDir)..\\..\\ABC\\ccc\\1234\\ccc_am_system\\host;$(SolDir)..\\..\\ABC\\ccc\\1234\\components\\fds\\ab_cdef_1.0\\host; $(SolDir)..\\..\\ABC\\ccc\\1234\\somethingelse;"
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.