const regex = /(\$.*?ccc\\1234\\.*?;)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\$.*?ccc\\\\1234\\\\.*?;)', 'gm')
const str = `\$(SolDir)..\\..\\ABC\\ccc\\1234\\ccc_am_system;\$(SolDir)..\\..\\ABC\\ccc\\1234\\ccc_am_system\\host;\$(SolDir)..\\..\\ABC\\ccc\\1234\\components\\fds\\ab_cdef_1.0\\host; \$(SolDir)..\\..\\ABC\\ccc\\1234\\somethingelse;`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);