import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(/$|/app/business\\-signup|/(?:[^a]..|.[^p].|..[^p]).*)";
final String string = "Expected excluded URLs:\n\n"
+ "/app\n"
+ "/app/\n"
+ "/app/abc\n"
+ "/app/abc?test=1\n"
+ "...\n"
+ "Expected included URLs:\n\n"
+ "/app/business-signup\n"
+ "/\n"
+ "/?test=1\n"
+ "/about\n"
+ "/about/abc\n"
+ "...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}