import re
regex = re.compile(r"^(/$|/app/business\-signup|/(?:[^a]..|.[^p].|..[^p]).*)", flags=re.MULTILINE)
test_str = ("Expected excluded URLs:\n\n"
"/app\n"
"/app/\n"
"/app/abc\n"
"/app/abc?test=1\n"
"...\n"
"Expected included URLs:\n\n"
"/app/business-signup\n"
"/\n"
"/?test=1\n"
"/about\n"
"/about/abc\n"
"...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")