// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(/$|/app/business\-signup|/(?:[^a]..|.[^p].|..[^p]).*)").unwrap();
let string = "Expected excluded URLs:
/app
/app/
/app/abc
/app/abc?test=1
...
Expected included URLs:
/app/business-signup
/
/?test=1
/about
/about/abc
...";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}