re = /^(\/$|\/app\/business\-signup|\/(?:[^a]..|.[^p].|..[^p]).*)/m
str = 'Expected excluded URLs:
/app
/app/
/app/abc
/app/abc?test=1
...
Expected included URLs:
/app/business-signup
/
/?test=1
/about
/about/abc
...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end