#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([^[:punct:]]*[[:punct:]][^[:punct:]]*)[[:punct:]]"
Local $sString = "A/B/C/D"
Local $sSubst = "\1*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)