using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^[:punct:]]*[[:punct:]][^[:punct:]]*)[[:punct:]]";
string substitution = @"\1*";
string input = @"A/B/C/D";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}