import re
regex = re.compile(r"([^[:punct:]]*[[:punct:]][^[:punct:]]*)[[:punct:]]")
test_str = "A/B/C/D"
subst = "\\1*"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)