const regex = /([^[:punct:]]*[[:punct:]][^[:punct:]]*)[[:punct:]]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^[:punct:]]*[[:punct:]][^[:punct:]]*)[[:punct:]]', '')
const str = `A/B/C/D`;
const subst = `\1*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);