re = /([^[:punct:]]*[[:punct:]][^[:punct:]]*)[[:punct:]]/
str = 'A/B/C/D'
subst = '\\1*'
result = str.sub(re, subst)
# Print the result of the substitution
puts result