#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\/\*([^\\n]*[\\n]?)*\*\/"
Local $sString = "22.5556445656 dfgdfgd if if if (asdfasdfasdfasdf" & @CRLF & _
"//asdfasdfasdf" & @CRLF & _
"/*asdfasdfasdfasdfasdf" & @CRLF & _
"asdfasdfasfasf" & @CRLF & _
"asdf*/" & @CRLF & _
"" & @CRLF & _
"/*sadfasdfasdfasdf*/" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)