re = /\/\*([^\\n]*[\\n]?)*\*\//
str = '22.5556445656 dfgdfgd if if if (asdfasdfasdfasdf
//asdfasdfasdf
/*asdfasdfasdfasdfasdf
asdfasdfasfasf
asdf*/
/*sadfasdfasdfasdf*/
'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result