use strict;
my $str = '22.5556445656 dfgdfgd if if if (asdfasdfasdfasdf
//asdfasdfasdf
/*asdfasdfasdfasdfasdf
asdfasdfasfasf
asdf*/
/*sadfasdfasdfasdf*/
';
my $regex = qr/\/\*([^\\n]*[\\n]?)*\*\//p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";