using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\*([^\\n]*[\\n]?)*\*\/";
string substitution = @"";
string input = @"22.5556445656 dfgdfgd if if if (asdfasdfasdfasdf
//asdfasdfasdf
/*asdfasdfasdfasdfasdf
asdfasdfasfasf
asdf*/
/*sadfasdfasdfasdf*/
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}