#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^|]+$)"
Local $sString = "Sample text for testing:" & @CRLF & _
"abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ" & @CRLF & _
"0123456789 _+-.,!@#$%^&*();\/|<>"'" & @CRLF & _
"12345 -98.7 3.141 .6180 \9,000 +42" & @CRLF & _
"555.123.4567 +1-(800)-555-2468" & @CRLF & _
"foo@demo.net bar.ba@test.co.uk" & @CRLF & _
"www.demo.com http://foo.co\.uk/" & @CRLF & _
"http://regexr.com/foo.html?q=bar" & @CRLF & _
"https://mediatemple.net||Test "
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)