const regex = /([^|]+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^|]+$)', 'gm')
const str = `Sample text for testing:
abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ
0123456789 _+-.,!@#\$%^&*();\\/|<>"'
12345 -98.7 3.141 .6180 \\9,000 +42
555.123.4567 +1-(800)-555-2468
foo@demo.net bar.ba@test.co.uk
www.demo.com http://foo.co\\.uk/
http://regexr.com/foo.html?q=bar
https://mediatemple.net||Test `;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);