package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^|]+$)`)
var str = `Sample text for testing:
abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ
0123456789 _+-.,!@#$%^&*();\/|<>"'
12345 -98.7 3.141 .6180 \9,000 +42
555.123.4567 +1-(800)-555-2468
foo@demo.net bar.ba@test.co.uk
www.demo.com http://foo.co\.uk/
http://regexr.com/foo.html?q=bar
https://mediatemple.net||Test `
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}