#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^\d\n]+)\d*.*$"
Local $sString = "abc123" & @CRLF & _
"#$%@#<>@<123" & @CRLF & _
"abc" & @CRLF & _
"abc @#@#@-122" & @CRLF & _
"a123b456" & @CRLF & _
"asdsaadsads456sdffdssfsfsfdsdfdsf978dsffddfssdf456dssdffsd456dfs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")