using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^\d\n]+)\d*.*$";
string input = @"abc123
#$%@#<>@<123
abc
abc @#@#@-122
a123b456
asdsaadsads456sdffdssfsfsfdsdfdsf978dsffddfssdf456dssdffsd456dfs";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}