re = /^([^\d\n]+)\d*.*$/m
str = 'abc123
#$%@#<>@<123
abc
abc @#@#@-122
a123b456
asdsaadsads456sdffdssfsfsfdsdfdsf978dsffddfssdf456dssdffsd456dfs'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end