package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^\d\n]+)\d*.*$`)
var str = `abc123
#$%@#<>@<123
abc
abc @#@#@-122
a123b456
asdsaadsads456sdffdssfsfsfdsdfdsf978dsffddfssdf456dssdffsd456dfs`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}