$re = '/^([^\d\n]+)\d*.*$/m';
$str = 'abc123
#$%@#<>@<123
abc
abc @#@#@-122
a123b456
asdsaadsads456sdffdssfsfsfdsdfdsf978dsffddfssdf456dssdffsd456dfs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);