import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![a-z])([\\,\\.\\?]+)?(\\s[\\,\\.\\?]+)?";
final String string = "'Im Herzen des idyllischen Dorfes Bergens werden Sie die Erholung finden,,, die Sie im Urlaub suchen. Unser Ferienhaus ist innen in modernem Design ausgestattet, \n"
+ " was reizvoll im Kontrast zum traditionellen Äußeren des Hauses steht. Sie erreichen den Sandstrand www.regexr.com/ von Bergens fußläufig in 5 Minuten und zum \n"
+ " Ortszentrum kommen Sie ebenfalls in 5 Minuten. Dort http://www.regexr.com erreichen Sie eine Supermarkt, Sparkasse, sowie Bäcker und Cafés... Es stehen zwei Wohnungen \n"
+ " zur Verfügung, die Ihnen den höchsten Kompfort anbieten? ? ?'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}