const regex = /(?<![a-z])([\,\.\?]+)?(\s[\,\.\?]+)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![a-z])([\\,\\.\\?]+)?(\\s[\\,\\.\\?]+)?', 'g')
const str = `'Im Herzen des idyllischen Dorfes Bergens werden Sie die Erholung finden,,, die Sie im Urlaub suchen. Unser Ferienhaus ist innen in modernem Design ausgestattet,
was reizvoll im Kontrast zum traditionellen Äußeren des Hauses steht. Sie erreichen den Sandstrand www.regexr.com/ von Bergens fußläufig in 5 Minuten und zum
Ortszentrum kommen Sie ebenfalls in 5 Minuten. Dort http://www.regexr.com erreichen Sie eine Supermarkt, Sparkasse, sowie Bäcker und Cafés... Es stehen zwei Wohnungen
zur Verfügung, die Ihnen den höchsten Kompfort anbieten? ? ?'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}