import re
regex = re.compile(r"(?<![a-z])([\,\.\?]+)?(\s[\,\.\?]+)?")
test_str = ("'Im Herzen des idyllischen Dorfes Bergens werden Sie die Erholung finden,,, die Sie im Urlaub suchen. Unser Ferienhaus ist innen in modernem Design ausgestattet, \n"
" was reizvoll im Kontrast zum traditionellen Äußeren des Hauses steht. Sie erreichen den Sandstrand www.regexr.com/ von Bergens fußläufig in 5 Minuten und zum \n"
" Ortszentrum kommen Sie ebenfalls in 5 Minuten. Dort http://www.regexr.com erreichen Sie eine Supermarkt, Sparkasse, sowie Bäcker und Cafés... Es stehen zwei Wohnungen \n"
" zur Verfügung, die Ihnen den höchsten Kompfort anbieten? ? ?'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")