re = /(?<![a-z])([\,\.\?]+)?(\s[\,\.\?]+)?/
str = '\'Im Herzen des idyllischen Dorfes Bergens werden Sie die Erholung finden,,, die Sie im Urlaub suchen. Unser Ferienhaus ist innen in modernem Design ausgestattet,
was reizvoll im Kontrast zum traditionellen Äußeren des Hauses steht. Sie erreichen den Sandstrand www.regexr.com/ von Bergens fußläufig in 5 Minuten und zum
Ortszentrum kommen Sie ebenfalls in 5 Minuten. Dort http://www.regexr.com erreichen Sie eine Supermarkt, Sparkasse, sowie Bäcker und Cafés... Es stehen zwei Wohnungen
zur Verfügung, die Ihnen den höchsten Kompfort anbieten? ? ?\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end