use strict;
my $str = '\'Im Herzen des idyllischen Dorfes Bergens werden Sie die Erholung finden,,, die Sie im Urlaub suchen. Unser Ferienhaus ist innen in modernem Design ausgestattet,
was reizvoll im Kontrast zum traditionellen Äußeren des Hauses steht. Sie erreichen den Sandstrand www.regexr.com/ von Bergens fußläufig in 5 Minuten und zum
Ortszentrum kommen Sie ebenfalls in 5 Minuten. Dort http://www.regexr.com erreichen Sie eine Supermarkt, Sparkasse, sowie Bäcker und Cafés... Es stehen zwei Wohnungen
zur Verfügung, die Ihnen den höchsten Kompfort anbieten? ? ?\'';
my $regex = qr/(?<![a-z])([\,\.\?]+)?(\s[\,\.\?]+)?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}